Home Support Projectors BrightLink Series Epson BrightLink 1485Fi

Do the projector's interactive features work with Linux?

  • Yes, they work with the following Linux operating systems:

    • Ubuntu 19.04
    • Ubuntu 18.04 LTS
    • Ubuntu 16.04 LTS

    The Ubuntu drivers support interactivity. You do not need to install additional drivers.

    Note: The Easy Interactive Tools software, Easy Interactive Driver, and DuoLink are not supported with Linux. For robust interactivity, you need third-party Linux-compatible interactive software (not included with the projector).

Published:  14-Nov-2019 Was this helpful​? Thank you for the feedback!
Please tell us why this was not helpful.​
Please enter a valid email address