Home Support Projectors EB Series Epson BrightLink EB-725Wi

Which driver do I need to install on my computer to use the interactive features?

  • Windows and Linux systems support the projector's interactive features with built-in drivers. A Mac requires the Easy Interactive Driver to be installed. See below for the supported operating systems.

    Windows

    The interactive features are supported on the following Windows operating systems:

    • Windows 10 (Windows 10 Home and Pro 32- and 64-bit)
    • Windows 8/8.1 (Windows 8 Enterprise and Pro 32- and 64-bit)
    • Windows 7 (all editions except for Starter)
    • Windows Vista (all editions except for Starter)

    Linux

    The interactive features are supported by the following Linux drivers:

    • Ubuntu 19.04
    • Ubuntu 18.04 LTS
    • Ubuntu 17.04
    • Ubuntu 16.10
    • Ubuntu 16.04 LTS
    • Ubuntu 15.10

    Mac

    The Easy Interactive Driver must be installed to use the interactive features with the following Mac operating systems:

    • macOS 11.x
    • macOS 10.15.x
    • macOS 10.14.x
    • macOS 10.13.x
    • macOS 10.12.x
    • OS X 10.11.x

    Note: For robust interactive features in Linux, you need Linux-compatible interactive software (not included with the projector). In Windows and Mac, the Easy Interactive Tools software provides more interactive features than the projector's built-in interactive tools.

Published:  17-Jun-2021 Was this helpful? Thank you for the feedback!
Was this helpful?
Please tell us why this was not helpful.
Please enter a valid email address